use strict;
my $str = '# FirstWordInHeading another Word
# test Sentence. Test sentence
## test1 Test2 Test3
### Test1 Test2 Test3
## test1 test2 test3
Test1 # test2 Test3';
my $regex = qr/(?<=#).*?([A-Z]\S+)|(?!^)\G.*?([A-Z]\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}