#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<a href="http:\/\/decorwind.ru\/category\/.*?" rel="category tag">(.*?)<\/a>"
Local $sString = "<a href="http://decorwind.ru/category/handmade/" rel="category tag">HandMade</a> <a href="http://decorwind.ru/category/handmade/iz-staryx-veshhej/" rel="category tag">Из старых вещей</a> <a href="http://decorwind.ru/category/dekor/prazdniki/" rel="category tag">Праздники</a> <a href="http://decorwind.ru/category/handmade/shem-i-vyazhem/" rel="category tag">Шьем и вяжем</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")