import Foundation
let pattern = #"<a href="http:\/\/decorwind.ru\/category\/.*?" rel="category tag">(.*?)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"<a href="http://decorwind.ru/category/handmade/" rel="category tag">HandMade</a> <a href="http://decorwind.ru/category/handmade/iz-staryx-veshhej/" rel="category tag">Из старых вещей</a> <a href="http://decorwind.ru/category/dekor/prazdniki/" rel="category tag">Праздники</a> <a href="http://decorwind.ru/category/handmade/shem-i-vyazhem/" rel="category tag">Шьем и вяжем</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)