// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<a href="http:\/\/decorwind.ru\/category\/.*?" rel="category tag">(.*?)<\/a>"#).unwrap();
let string = "<a href=\"http://decorwind.ru/category/handmade/\" rel=\"category tag\">HandMade</a> <a href=\"http://decorwind.ru/category/handmade/iz-staryx-veshhej/\" rel=\"category tag\">Из старых вещей</a> <a href=\"http://decorwind.ru/category/dekor/prazdniki/\" rel=\"category tag\">Праздники</a> <a href=\"http://decorwind.ru/category/handmade/shem-i-vyazhem/\" rel=\"category tag\">Шьем и вяжем</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}