package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<a href="http:\/\/decorwind.ru\/category\/.*?" rel="category tag">(.*?)<\/a>`)
var str = `<a href="http://decorwind.ru/category/handmade/" rel="category tag">HandMade</a> <a href="http://decorwind.ru/category/handmade/iz-staryx-veshhej/" rel="category tag">Из старых вещей</a> <a href="http://decorwind.ru/category/dekor/prazdniki/" rel="category tag">Праздники</a> <a href="http://decorwind.ru/category/handmade/shem-i-vyazhem/" rel="category tag">Шьем и вяжем</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}