$re = '/<a href="http:\/\/decorwind.ru\/category\/.*?" rel="category tag">(.*?)<\/a>/is';
$str = '<a href="http://decorwind.ru/category/handmade/" rel="category tag">HandMade</a> <a href="http://decorwind.ru/category/handmade/iz-staryx-veshhej/" rel="category tag">Из старых вещей</a> <a href="http://decorwind.ru/category/dekor/prazdniki/" rel="category tag">Праздники</a> <a href="http://decorwind.ru/category/handmade/shem-i-vyazhem/" rel="category tag">Шьем и вяжем</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);