using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""http:\/\/decorwind.ru\/category\/.*?"" rel=""category tag"">(.*?)<\/a>";
string input = @"<a href=""http://decorwind.ru/category/handmade/"" rel=""category tag"">HandMade</a> <a href=""http://decorwind.ru/category/handmade/iz-staryx-veshhej/"" rel=""category tag"">Из старых вещей</a> <a href=""http://decorwind.ru/category/dekor/prazdniki/"" rel=""category tag"">Праздники</a> <a href=""http://decorwind.ru/category/handmade/shem-i-vyazhem/"" rel=""category tag"">Шьем и вяжем</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}