package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Cust=([^,]+)(?:,Region Info=([^,]*))?(?:,Data=(.*))?$`)
var str = `Cust=abc,Region Info=xyz,Data=123
Cust=abd,Region Info=xyz,Data=124
Cust=acc hit,Data=125
Cust=abc,Region Info=xyz,Data=126
Cust=abg nss,Region Info=xaz,Data=127
Cust=evc,Region Info=atz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}