re = /^Cust=([^,]+)(?:,Region Info=([^,]*))?(?:,Data=(.*))?$/m
str = 'Cust=abc,Region Info=xyz,Data=123
Cust=abd,Region Info=xyz,Data=124
Cust=acc hit,Data=125
Cust=abc,Region Info=xyz,Data=126
Cust=abg nss,Region Info=xaz,Data=127
Cust=evc,Region Info=atz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end