import re
regex = re.compile(r"^Cust=([^,]+)(?:,Region Info=([^,]*))?(?:,Data=(.*))?$", flags=re.MULTILINE)
test_str = ("Cust=abc,Region Info=xyz,Data=123\n"
"Cust=abd,Region Info=xyz,Data=124\n"
"Cust=acc hit,Data=125\n"
"Cust=abc,Region Info=xyz,Data=126\n"
"Cust=abg nss,Region Info=xaz,Data=127\n"
"Cust=evc,Region Info=atz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")