import Foundation
let pattern = #"^Cust=([^,]+)(?:,Region Info=([^,]*))?(?:,Data=(.*))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Cust=abc,Region Info=xyz,Data=123
Cust=abd,Region Info=xyz,Data=124
Cust=acc hit,Data=125
Cust=abc,Region Info=xyz,Data=126
Cust=abg nss,Region Info=xaz,Data=127
Cust=evc,Region Info=atz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)