// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Cust=([^,]+)(?:,Region Info=([^,]*))?(?:,Data=(.*))?$").unwrap();
let string = "Cust=abc,Region Info=xyz,Data=123
Cust=abd,Region Info=xyz,Data=124
Cust=acc hit,Data=125
Cust=abc,Region Info=xyz,Data=126
Cust=abg nss,Region Info=xaz,Data=127
Cust=evc,Region Info=atz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}