import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Cust=([^,]+)(?:,Region Info=([^,]*))?(?:,Data=(.*))?$";
final String string = "Cust=abc,Region Info=xyz,Data=123\n"
+ "Cust=abd,Region Info=xyz,Data=124\n"
+ "Cust=acc hit,Data=125\n"
+ "Cust=abc,Region Info=xyz,Data=126\n"
+ "Cust=abg nss,Region Info=xaz,Data=127\n"
+ "Cust=evc,Region Info=atz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}