#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\((\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\(?\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\d+ (AND|OR) )+\d+$"
Local $sString = "1 AND 2 AND 3 AND 4" & @CRLF & _
"1 AND 2 AND (3 AND 4)" & @CRLF & _
"1 AND 2 AND 3 (AND 4)" & @CRLF & _
"(1 AND 2 AND 3 AND 4" & @CRLF & _
")1 AND 2 AND 3 AND 4" & @CRLF & _
"(1 AND 2 AND 3) AND 4" & @CRLF & _
"(1 AND 2)(AND 3 AND 4)" & @CRLF & _
"((1 AND 2 AND 3 AND 4)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")