package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\((\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\(?\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\d+ (AND|OR) )+\d+$`)
var str = `1 AND 2 AND 3 AND 4
1 AND 2 AND (3 AND 4)
1 AND 2 AND 3 (AND 4)
(1 AND 2 AND 3 AND 4
)1 AND 2 AND 3 AND 4
(1 AND 2 AND 3) AND 4
(1 AND 2)(AND 3 AND 4)
((1 AND 2 AND 3 AND 4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}