re = /^\((\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\(?\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\d+ (AND|OR) )+\d+$/im
str = '1 AND 2 AND 3 AND 4
1 AND 2 AND (3 AND 4)
1 AND 2 AND 3 (AND 4)
(1 AND 2 AND 3 AND 4
)1 AND 2 AND 3 AND 4
(1 AND 2 AND 3) AND 4
(1 AND 2)(AND 3 AND 4)
((1 AND 2 AND 3 AND 4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end