# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?P<Flat>([A-Za-z0-9\\/\-]*\w\s*)*)(\,|\s|\|)*(?P<Building>([A-Za-z0-9\s\\/\-]*\w\s*)(\,|\s)*)(?P<OtherPart>([A-Za-z\s\\/\-\,]*\w\s*)(\,|\s)*)(?P<PinCode>([0-9]{6}))/\1\2 \3/gm;t' <<< "168-B-A-3, LIG Flats, yur Vihar Phase-3, Vasundhra nclave, East Delhi, Vasundhra nclave, Delhi, 110096"