const regex = new RegExp('(?P<Flat>([A-Za-z0-9\\/\\-]*\\w\\s*)*)(\\,|\\s|\\|)*(?P<Building>([A-Za-z0-9\\s\\/\\-]*\\w\\s*)(\\,|\\s)*)(?P<OtherPart>([A-Za-z\\s\\/\\-\\,]*\\w\\s*)(\\,|\\s)*)(?P<PinCode>([0-9]{6}))', 'gm')
const str = `168-B-A-3, LIG Flats, yur Vihar Phase-3, Vasundhra nclave, East Delhi, Vasundhra nclave, Delhi, 110096`;
const subst = `\1\2 \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);