#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?P<Flat>([A-Za-z0-9\/\-]*\w\s*)*)(\,|\s|\|)*(?P<Building>([A-Za-z0-9\s\/\-]*\w\s*)(\,|\s)*)(?P<OtherPart>([A-Za-z\s\/\-\,]*\w\s*)(\,|\s)*)(?P<PinCode>([0-9]{6}))"
Local $sString = "168-B-A-3, LIG Flats, yur Vihar Phase-3, Vasundhra nclave, East Delhi, Vasundhra nclave, Delhi, 110096"
Local $sSubst = "\1\2 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)