using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<Flat>([A-Za-z0-9\/\-]*\w\s*)*)(\,|\s|\|)*(?P<Building>([A-Za-z0-9\s\/\-]*\w\s*)(\,|\s)*)(?P<OtherPart>([A-Za-z\s\/\-\,]*\w\s*)(\,|\s)*)(?P<PinCode>([0-9]{6}))";
string substitution = @"\1\2 \3";
string input = @"168-B-A-3, LIG Flats, yur Vihar Phase-3, Vasundhra nclave, East Delhi, Vasundhra nclave, Delhi, 110096";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}