// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<Flat>([A-Za-z0-9\/\-]*\w\s*)*)(\,|\s|\|)*(?P<Building>([A-Za-z0-9\s\/\-]*\w\s*)(\,|\s)*)(?P<OtherPart>([A-Za-z\s\/\-\,]*\w\s*)(\,|\s)*)(?P<PinCode>([0-9]{6}))").unwrap();
let string = "168-B-A-3, LIG Flats, yur Vihar Phase-3, Vasundhra nclave, East Delhi, Vasundhra nclave, Delhi, 110096";
let substitution = "\\1\\2 \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}