#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/?({[a-zA-Z_0-9]*})\/?"
Local $sString = "# Valid" & @CRLF & _
"/test3/{id}/{test}/{id}" & @CRLF & _
"" & @CRLF & _
"# Valid" & @CRLF & _
"/admin/{slug}" & @CRLF & _
"" & @CRLF & _
"# Not Valid" & @CRLF & _
"/test3{id}{test}" & @CRLF & _
"" & @CRLF & _
"# Not Valid" & @CRLF & _
"/test/{id}/yyy/{dd}/dwdw/{wd}{d}" & @CRLF & _
"" & @CRLF & _
"# Valid" & @CRLF & _
"/user/post/{id}" & @CRLF & _
"" & @CRLF & _
"# Valid" & @CRLF & _
"/{tt}/{t}" & @CRLF & _
"" & @CRLF & _
"# Valid" & @CRLF & _
"/test/{id}/yyy/{dd}////dwdw/{wd}/{d}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")