import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/?(\\{[a-zA-Z_0-9]*\\})\\/?";
final String string = "# Valid\n"
+ "/test3/{id}/{test}/{id}\n\n"
+ "# Valid\n"
+ "/admin/{slug}\n\n"
+ "# Not Valid\n"
+ "/test3{id}{test}\n\n"
+ "# Not Valid\n"
+ "/test/{id}/yyy/{dd}/dwdw/{wd}{d}\n\n"
+ "# Valid\n"
+ "/user/post/{id}\n\n"
+ "# Valid\n"
+ "/{tt}/{t}\n\n"
+ "# Valid\n"
+ "/test/{id}/yyy/{dd}////dwdw/{wd}/{d}\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}