const regex = /\/?({[a-zA-Z_0-9]*})\/?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/?({[a-zA-Z_0-9]*})\\\/?', 'g')
const str = `# Valid
/test3/{id}/{test}/{id}
# Valid
/admin/{slug}
# Not Valid
/test3{id}{test}
# Not Valid
/test/{id}/yyy/{dd}/dwdw/{wd}{d}
# Valid
/user/post/{id}
# Valid
/{tt}/{t}
# Valid
/test/{id}/yyy/{dd}////dwdw/{wd}/{d}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}