import re
regex = re.compile(r"\/?({[a-zA-Z_0-9]*})\/?")
test_str = ("# Valid\n"
"/test3/{id}/{test}/{id}\n\n"
"# Valid\n"
"/admin/{slug}\n\n"
"# Not Valid\n"
"/test3{id}{test}\n\n"
"# Not Valid\n"
"/test/{id}/yyy/{dd}/dwdw/{wd}{d}\n\n"
"# Valid\n"
"/user/post/{id}\n\n"
"# Valid\n"
"/{tt}/{t}\n\n"
"# Valid\n"
"/test/{id}/yyy/{dd}////dwdw/{wd}/{d}\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")