// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/?({[a-zA-Z_0-9]*})\/?").unwrap();
let string = "# Valid
/test3/{id}/{test}/{id}
# Valid
/admin/{slug}
# Not Valid
/test3{id}{test}
# Not Valid
/test/{id}/yyy/{dd}/dwdw/{wd}{d}
# Valid
/user/post/{id}
# Valid
/{tt}/{t}
# Valid
/test/{id}/yyy/{dd}////dwdw/{wd}/{d}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}