import Foundation
let pattern = #"\/?({[a-zA-Z_0-9]*})\/?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
# Valid
/test3/{id}/{test}/{id}
# Valid
/admin/{slug}
# Not Valid
/test3{id}{test}
# Not Valid
/test/{id}/yyy/{dd}/dwdw/{wd}{d}
# Valid
/user/post/{id}
# Valid
/{tt}/{t}
# Valid
/test/{id}/yyy/{dd}////dwdw/{wd}/{d}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)