#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=["'])(?:"[^"\\]*(?:\\[\s\S][^"\\]*)*"|'[^'\\]*(?:\\[\s\S][^'\\]*)*')|(#.*$)"
Local $sString = "class AAA:" & @CRLF & _
" """" & @CRLF & _
" item" & @CRLF & _
" """" & @CRLF & _
" ''''" & @CRLF & _
" SRC_TYPE = (" & @CRLF & _
" ('cs', 'src C# for all'), # this is a comment a 'comment'" & @CRLF & _
" ('cpp', 'C++')," & @CRLF & _
" ('ascript', 'a '),#djshdjshdjshds" & @CRLF & _
" ('script', 'tst C#')" & @CRLF & _
" )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")