$re = '/(?=["\'])(?:"[^"\\\\]*(?:\\\\[\s\S][^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\[\s\S][^\'\\\\]*)*\')|(#.*$)/m';
$str = 'class AAA:
"""
item
"""
\'\'\'\'
SRC_TYPE = (
(\'cs\', \'src C# for all\'), # this is a comment a \'comment\'
(\'cpp\', \'C++\'),
(\'ascript\', \'a \'),#djshdjshdjshds
(\'script\', \'tst C#\')
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);