import re
regex = re.compile(r"(?=[\"'])(?:\"[^\"\\]*(?:\\[\s\S][^\"\\]*)*\"|'[^'\\]*(?:\\[\s\S][^'\\]*)*')|(#.*$)", flags=re.MULTILINE)
test_str = ("class AAA:\n"
" \"\"\"\n"
" item\n"
" \"\"\"\n"
" ''''\n"
" SRC_TYPE = (\n"
" ('cs', 'src C# for all'), # this is a comment a 'comment'\n"
" ('cpp', 'C++'),\n"
" ('ascript', 'a '),#djshdjshdjshds\n"
" ('script', 'tst C#')\n"
" )")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")