import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[\"'])(?:\"[^\"\\\\]*(?:\\\\[\\s\\S][^\"\\\\]*)*\"|'[^'\\\\]*(?:\\\\[\\s\\S][^'\\\\]*)*')|(#.*$)";
final String string = "class AAA:\n"
+ " \"\"\"\n"
+ " item\n"
+ " \"\"\"\n"
+ " ''''\n"
+ " SRC_TYPE = (\n"
+ " ('cs', 'src C# for all'), # this is a comment a 'comment'\n"
+ " ('cpp', 'C++'),\n"
+ " ('ascript', 'a '),#djshdjshdjshds\n"
+ " ('script', 'tst C#')\n"
+ " )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}