using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[""'])(?:""[^""\\]*(?:\\[\s\S][^""\\]*)*""|'[^'\\]*(?:\\[\s\S][^'\\]*)*')|(#.*$)";
string input = @"class AAA:
""""
item
""""
''''
SRC_TYPE = (
('cs', 'src C# for all'), # this is a comment a 'comment'
('cpp', 'C++'),
('ascript', 'a '),#djshdjshdjshds
('script', 'tst C#')
)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}