package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)process name:\s+(?<process_name>[^ ]+)`)
var str = `<30>1 2023-12-13T06:22:20.197Z 10.205.101.94 4 CGA3001I [sev="INFO" msg="Event" event="Data is getting from process name: C:\\ProgramFiles\\notepad.exe. Now we can try to write the logs. Mode: Operational"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}