import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "process name:\\s+(?<process_name>[^ ]+)";
final String string = "<30>1 2023-12-13T06:22:20.197Z 10.205.101.94 4 CGA3001I [sev=\"INFO\" msg=\"Event\" event=\"Data is getting from process name: C:\\\\ProgramFiles\\\\notepad.exe. Now we can try to write the logs. Mode: Operational\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}