const regex = /process name:\s+(?<process_name>[^ ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('process name:\\s+(?<process_name>[^ ]+)', 'gm')
const str = `<30>1 2023-12-13T06:22:20.197Z 10.205.101.94 4 CGA3001I [sev="INFO" msg="Event" event="Data is getting from process name: C:\\\\ProgramFiles\\\\notepad.exe. Now we can try to write the logs. Mode: Operational"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}