// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)process name:\s+(?<process_name>[^ ]+)").unwrap();
let string = "<30>1 2023-12-13T06:22:20.197Z 10.205.101.94 4 CGA3001I [sev=\"INFO\" msg=\"Event\" event=\"Data is getting from process name: C:\\\\ProgramFiles\\\\notepad.exe. Now we can try to write the logs. Mode: Operational\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}