re = /process name:\s+(?<process_name>[^ ]+)/m
str = '<30>1 2023-12-13T06:22:20.197Z 10.205.101.94 4 CGA3001I [sev="INFO" msg="Event" event="Data is getting from process name: C:\\\\ProgramFiles\\\\notepad.exe. Now we can try to write the logs. Mode: Operational"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end