#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s@]*[A-Za-z][^\s@]*@[^\s@]+\.[a-z]{2,}$"
Local $sString = "_@gmail.com" & @CRLF & _
"_@gmail.com" & @CRLF & _
"8@gmail.com" & @CRLF & _
"8@gmail.com" & @CRLF & _
"88@gmail.com" & @CRLF & _
"8@gmail.com" & @CRLF & _
"test@gmail.com" & @CRLF & _
"1234@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")