import re
regex = re.compile(r"^[^\s@]*[A-Za-z][^\s@]*@[^\s@]+\.[a-z]{2,}$", flags=re.MULTILINE)
test_str = ("_@gmail.com\n"
"_@gmail.com\n"
"8@gmail.com\n"
"8@gmail.com\n"
"88@gmail.com\n"
"8@gmail.com\n"
"test@gmail.com\n"
"1234@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")