using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s@]*[A-Za-z][^\s@]*@[^\s@]+\.[a-z]{2,}$";
string input = @"_@gmail.com
_@gmail.com
8@gmail.com
8@gmail.com
88@gmail.com
8@gmail.com
test@gmail.com
1234@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}