$re = '/^[^\s@]*[A-Za-z][^\s@]*@[^\s@]+\.[a-z]{2,}$/m';
$str = '_@gmail.com
_@gmail.com
8@gmail.com
8@gmail.com
88@gmail.com
8@gmail.com
test@gmail.com
1234@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);