const regex = new RegExp('^[^\\s@]*[A-Za-z][^\\s@]*@[^\\s@]+\\.[a-z]{2,}$', 'gm')
const str = `_@gmail.com
_@gmail.com
8@gmail.com
8@gmail.com
88@gmail.com
8@gmail.com
test@gmail.com
1234@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}