re = /^[^\s@]*[A-Za-z][^\s@]*@[^\s@]+\.[a-z]{2,}$/m
str = '_@gmail.com
_@gmail.com
8@gmail.com
8@gmail.com
88@gmail.com
8@gmail.com
test@gmail.com
1234@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end