import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<full_tag><\\s*+(?<name>[^\\s>]++)[^>]*+>(?>[^<>]++|(?&full_tag))*+</\\s*+\\g\\{name\\}\\s*+>)(*SKIP)(*F)|<\\s*+(?<bad_tag>[^\\s>]++)[^>]*+>[^<>]++";
final String string = "<p>hgfgff</p>\n"
+ "<p>ffdffd</h2>\n"
+ "<p>zsfdffd</h6>\n"
+ "<p>hgfgff</p>\n"
+ "<p>hgfgff<h1><b>text</b><u>text</u></h1></p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}