re = /(?<full_tag><\s*+(?<name>[^\s>]++)[^>]*+>(?>[^<>]++|(?&full_tag))*+<\/\s*+\g{name}\s*+>)(*SKIP)(*F)|<\s*+(?<bad_tag>[^\s>]++)[^>]*+>[^<>]++/m
str = '<p>hgfgff</p>
<p>ffdffd</h2>
<p>zsfdffd</h6>
<p>hgfgff</p>
<p>hgfgff<h1><b>text</b><u>text</u></h1></p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end