#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>"
Local $sString = "<h1>This is a large heading</h1>" & @CRLF & _
"<p>This is a sample content paragraph.</p>" & @CRLF & _
"<h2 style="somestyle">This header line</h2>" & @CRLF & _
"<p>This is another content paragraph.</p>" & @CRLF & _
"<h2>Another header line</h2>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)