import Foundation
let pattern = #"<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style="somestyle">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)