$re = '/<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>/';
$str = '<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style="somestyle">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;