package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>`)
var str = `<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style="somestyle">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}