// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<h\d{1}(?:.*?)>(?<title>.*?)<\/h\d{1}>").unwrap();
let string = "<h1>This is a large heading</h1>
<p>This is a sample content paragraph.</p>
<h2 style=\"somestyle\">This header line</h2>
<p>This is another content paragraph.</p>
<h2>Another header line</h2>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}